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INTRODUCTION

This Sample Project Guide contains exercises for building a multimedia
show using Interactive layouts for a sporting goods company named Launch7.
Representatives at Launch7 want to promote their brand image and drive traffic
to their stores through a rich multimedia experience. 

This manual assumes that you are familiar with the features of QuarkXPress®.
If you are new to both QuarkXPress and Quark® Interactive Designer, familiar-
ize yourself with the QuarkXPress 7 feature set using A Guide to QuarkXPress 7,
QuarkXPress 7 Help, and A Guide to Interactive Designer before reading
this manual. 

GETTING STARTED

One of the advantages of multimedia is using the power of entertainment to
strengthen a brand image. For this project, you will create a multimedia show
and export it as a Projector file that can then be burned to CD for convenient
use at promotional events, trade shows, and corporate meetings. 

The “Welcome” page in the completed Launch7 multimedia show.

INTRODUCTION
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With Quark Interactive Designer, you can add background sound, interactive
buttons, video, and animations to your multimedia projects. 

In this project, you will see how easy it is to perform the following tasks in
Quark Interactive Designer:

• Create an On/Off button for playing and stopping background sound

• Create a menu with mouse-over effects

• Create an image sequence to animate a logo

• Add SWF (Flash) animation

• Add video and video controls

• Create a scrollable text box to display content

This guide does not contain instructions for the slide and transition effects
applied to the graphics on each page of the multimedia show. To see how
these graphics were configured, click the Script tab and the Page tab in the
Interactive palette. To learn more about sliding in and transitioning in
graphics, see the other sample project guides, in which these topics are
covered extensively. 

CREATING AN ON/OFF BUTTON TO PLAY AND STOP BACKGROUND SOUND

On/Off buttons are ideal for turning sound on or off in an exported file. In
addition, On/Off buttons can provide visual feedback to indicate when the
sound is on or off in a presentation. In this section, you will configure an
On/Off button to stop and play background sound and to display visual
indicators when an end user clicks the button. 

TURNING A PICTURE BOX INTO AN INTERACTIVE ON/OFF
BUTTON OBJECT

1 Open the “Launch7Show.qpt” file in the “Multimedia Show” folder, and then
save the file as “Launch7Show.qxp” in the “Multimedia Show” folder.

If the Nonmatching Preferences dialog box displays,
click Keep Project Settings.

2 Click the MultimediaShow layout in the bottom of the project window to
display the main Presentation layout for the multimedia show.

3 Make sure Window Þ Page Layout is checked. The Page Layout palette displays
two master pages and a layout page for each slide in the multimedia show.

GETTING STARTED
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The Page Layout palette of the “MultimediaShow” layout.

4 Click the A-SHOW CONTENT icon in the Page Layout palette. The “A-SHOW
CONTENT” master page displays.

The “A-SHOW CONTENT” master page contains items that display on layout pages
in the presentation. 

5 Select the empty picture box that displays in the master page.

The empty box displays in the “A-SHOW CONTENT” master page.

CREATING AN ON/OFF BUTTON TO PLAY AND STOP BACKGROUND SOUND
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6 To turn the box into a Button object, make sure Window Þ Interactive Palette
is checked to display the Interactive palette. 

7 In the Interactive palette, click the Object tab.

The Object tab of the Interactive palette lets you turn QuarkXPress items into
interactive objects.

8 Enter Button_SoundOnOff in the Object Name field.

9 With the picture box still selected, choose Button from the Object Type
drop-down menu.

10 Choose New from the Button drop-down menu. The New Interactive Layout
dialog box displays.

11 Enter ButtonSound in the Layout Name field. 

12 Choose On/Off from the Button Type drop-down menu. (The Width and
Height are automatically copied from the picture box you selected.)

The New Interactive Layout dialog box lets you create Button layouts.

13 Click OK. A new Button layout named ButtonSound displays.

CREATING AN ON/OFF BUTTON TO PLAY AND STOP BACKGROUND SOUND

4 | CREATING A MULTIMEDIA SHOW



When you turn a picture box in a Presentation layout into a Button object, a
new Button layout is created where you design the different states of the but-
ton. In addition, the original picture box in the Presentation layout becomes
a Composition Zones™ item. 

The new Button layout.

CREATING THE STATES OF THE INTERACTIVE ON/OFF
BUTTON OBJECT
In the ButtonSound layout, make sure Window Þ Page Layout is checked.
The Page Layout palette displays a page for each state of the On/Off Button.

Access each state of a Button layout using the Page Layout palette.

1 Double-click A-Master A in the Page Layout palette. The “A-Master A” master
page in the Button layout displays. 

CREATING AN ON/OFF BUTTON TO PLAY AND STOP BACKGROUND SOUND
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2 Open the Buttons library. Choose File Þ Open, open the “libraries” folder,
and then open the appropriate library. If you are using Mac OS®, open
the Buttons_Mac.qxl library. If you are using Windows®, open the
Buttons_Win.qxl library. The library displays.

Access graphics for the On/Off button by opening the appropriate library.

3 Select the sound graphic in the library and drag it to the master page of
the ButtonSound layout. Note how the graphic is identical in each state of
the button.

The sound graphic is stored in the library.

4 Update the content of the button states to create the button effects. For example,
we made the following updates:

You might need to ungroup the sound graphics (Item Þ Ungroup) on each
page to make the following changes.

• For the On-Over button state, we made the center graphic green to indicate
that the end user should click the button to turn the sound on. 

• For the Off-Over button state, we made the center graphic red to indicate that
the end user should click the button to turn the sound off. 

• For the On-Down and Off-Down button states, we deleted the background
graphic to make the button appear as compressed when the end user clicks it
in the On or Off states.

CREATING AN ON/OFF BUTTON TO PLAY AND STOP BACKGROUND SOUND
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The updated button states On-Up, On-Over, On-Down, and On-Hit.

5 To preview the button, choose Layout Þ Preview SWF Þ Preview Layout or
click Preview at the bottom of the Button layout. QuarkXPress launches
Flash Player and displays the exported version of the button. Note how the
button changes when you place your mouse over it and click it. 

6 When you are finished, switch back to the MultimediaShow layout using the
layout tabs at the bottom of the window or by choosing Layout Þ Go To.

You can create a Button layout the same way you create a Presentation layout by
choosing File Þ New Þ Project or Layout Þ New. However, when you use the
approach described above, the size of the original picture box is automatically
captured and used for the new Button layout.

CONFIGURING THE ON/OFF BUTTON OBJECT TO PLAY AND STOP
BACKGROUND SOUND
CONFIGURING THE ON/OFF BUTTON OBJECT TO PLAY
BACKGROUND SOUND

1 In the MultimediaShow layout, make sure Window Þ Page Layout is checked,
and then click the A-SHOW CONTENT icon in the Page Layout palette. The
“A-SHOW CONTENT” master page displays. 

2 Click the On/Off Button object in the “A-SHOW CONTENT” master page that
you just created in the previous section.

CREATING AN ON/OFF BUTTON TO PLAY AND STOP BACKGROUND SOUND
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Click the On/Off Button object you created in the previous section. 

3 In the Interactive palette, click the Event tab. 

4 Select Button_SoundOnOff in the list on the left side of the Event tab.

5 Choose Click Up On in the User Event drop-down menu. 

Configure the options in the User Event drop-down menu on the Event tab for
an On/Off button. 

6 Choose Sound Þ Play Background in the Action drop-down menu.

7 To create a path that will reference a sound file when the exported project runs: 

a. Choose External Reference in the Sound drop-down menu. The External
File Reference dialog box displays. 

Using this option to configure sound helps to keep the file size small.

b. Enter BackgroundSound in the Name field. 

c. Choose File in the Type drop-down menu. 

d. Click to locate the “bg_sound.mp3” sound file in the “sounds” folder of
the “Multimedia Show” folder.

e. Click OK.

CREATING AN ON/OFF BUTTON TO PLAY AND STOP BACKGROUND SOUND
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8 Enter 1 in the Fade In field to indicate that the sound should take one second
to fade in when the end user clicks the button to turn on the background music. 

Use the Event tab of the Interactive palette to configure the Click Up On state of
the On/Off Button object. 

CONFIGURING THE ON/OFF BUTTON OBJECT TO STOP
BACKGROUND SOUND

1 With Button_SoundOnOff still selected, choose Click Up Off in the User Event
drop-down menu. 

2 Choose Sound Þ Stop Background in the Action drop-down menu.

3 Enter 1 in the Fade Out field to specify that the sound should take 1 second
to fade out when the end user clicks the sound button to turn off the
background music. 

Use the Event tab of the Interactive palette to configure the Click Up Off state of
the On/Off Button object.

CREATING AN ON/OFF BUTTON TO PLAY AND STOP BACKGROUND SOUND
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PREVIEWING THE INTERACTIVE ON/OFF BUTTON OBJECT
The On/Off Button object displays on each layout page that has the
“A-SHOW CONTENT” master page applied. Therefore, when you preview the
“MultimediaShow” layout, you will see the On/Off Button object display on
all of the content pages in the multimedia show. 

To preview the sound button on the “Welcome” page 

1 Double-click page 2 in the Page Layout palette. The “Welcome” page displays.

2 Choose Layout Þ Preview SWF Þ Preview Page. QuarkXPress launches Flash
Player and displays the exported version of the page. 

3 Click the On/Off sound button to stop and start the background sound. Note
how the button changes when you place your mouse over it and click it.

PLAYING BACKGROUND SOUND AUTOMATICALLY WHEN THE EXPORTED

FILE IS LAUNCHED

1 In the MultimediaShow layout, make sure Window Þ Page Layout is
checked, and then double-click page 1 in the Page Layout palette. The
“Introduction” page displays. 

2 Make sure Window Þ Interactive Palette is checked to display the
Interactive palette.

3 In the Interactive palette, click the Script tab.

4 Click the button, and then enter IntroPageScript in the Script Name field.
A new script named “IntroPageScript” is created.

5 Select No Action in the Actions list. The Action drop-down menu displays.

6 Choose Sound Þ Play Background in the Action drop-down menu.

7 Choose BackgroundSound from the Sound drop-down menu. 

BackgroundSound is the external reference to the “bg_sound.mp3” file that
you created in the previous section. All references to sounds that you create
display in the Sound drop-menu for later use.

8 Enter 1 in the Fade In field to indicate that the sound should take one second
to fade in when the exported file is launched. The Play Background Sound
action is added to the script. 

CREATING AN ON/OFF BUTTON TO PLAY AND STOP BACKGROUND SOUND
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The Play Background Sound action is added to the script.

9 To run the script when the exported file is launched, click the Page tab. 

10 Select IntroPageScript from the Page Entry drop-down menu for page 1 to
indicate that when page 1 displays in the exported multimedia show, all of
the actions in the script will run, including the Play Background Sound action
you just configured. 

The script will run when the “Introduction” page (page 1) displays in the
exported file. 

11 To preview how the sound plays automatically, choose Layout Þ

Preview SWF Þ Preview Layout or click Preview at the bottom of the
Interactive layout. QuarkXPress launches Flash Player and the sound plays
automatically in the background. Click the sound button you created in the
previous section to stop and play the sound.

PLAYING BACKGROUND SOUND AUTOMATICALLY WHEN THE EXPORTED FILE IS LAUNCHED
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CREATING A MENU USING MASTER PAGES AND BUTTON BEHAVIORS

One way to create a consistent menu is to create a series of interactive objects
on a master page and configure them with button behaviors using the user
events available on the Event tab. 

In this section, you’ll do the following on the “A-SHOW CONTENT” master
page of the “MultimediaShow” layout:

1 Create the interactive objects for the menu that include a text box and a
mouse-over box for each menu item.

2 Configure the mouse-over effects for each menu item.

3 Name each page in the Interactive layout and configure the Click down user
events to display the appropriate page in the exported file.

CREATING THE INTERACTIVE OBJECTS FOR THE MENU
You’ll create two interactive objects for each item that displays in the menu.
The first interactive object is the text box for the menu item, and the second
interactive object is the mouse-over box that contains background color.

TURNING THE MENU ITEMS INTO INTERACTIVE OBJECTS
There are several text boxes that display as menu items in the “A-SHOW
CONTENT” master page. To turn the text boxes into interactive objects:

1 In the MultimediaShow layout, make sure Window Þ Page Layout is checked
to display the Page Layout palette.

2 Double-click A-SHOW CONTENT in the Page Layout palette. The “A-SHOW
CONTENT” master page displays the menu.

The menu in the “A-SHOW CONTENT” master page displays in the layout pages
that have the master page applied.

3 Make sure Window Þ Interactive Palette is checked to display the
Interactive palette.

CREATING A MENU USING MASTER PAGES AND BUTTON BEHAVIORS
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4 Click the Object tab in the Interactive palette.

5 In the A-SHOW CONTENT master page, select the text box that contains the
words “Our History”.

Select a text box in the menu on the “A-SHOW CONTENT” master page.

6 In the Object tab of the Interactive palette, enter Btn_OurHistory in the
Object Name field.

Enter a name in the Object Name field to turn the text box into an interactive object.

CREATING A MENU USING MASTER PAGES AND BUTTON BEHAVIORS
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7 Repeat the previous two steps until you have turned all of the text boxes in the
menu into interactive objects.

The interactive Button objects that display in the “A-SHOW CONTENT”
master page. 

CREATING THE INTERACTIVE OBJECTS FOR THE
MOUSE-OVER EFFECTS
To create boxes for the mouse-over effects: 

1 On the A-SHOW CONTENT master page, draw a picture box over the
Btn_OurHistory interactive object, and then select Launch7 Blue color
for its background.

2 With the new box still selected, enter the following values in the Classic
tab of the Measurements palette to position it directly in front of the
“Our History” text box:

X: 12 (horizontal position of the upper left corner)

Y: 293 (vertical position of the upper left corner)

W: 300 (width of the box)

H: 20 (height of the box)

CREATING A MENU USING MASTER PAGES AND BUTTON BEHAVIORS
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Position the mouse-over box directly over the “Our History” menu item.

3 To turn the new box into an interactive object, make sure Window Þ

Interactive Palette is checked to display the Interactive palette.

4 Click the Object tab in the Interactive palette.

5 With the new picture box still selected, in the Object tab of the Interactive
palette, enter Btn_OurHistory_Over in the Object Name field, and then choose
Initially Hidden from the Options drop-down menu.

You set the mouse-over boxes to Initially Hidden because the boxes only display
in the exported file when the end user places the mouse over the menu item.

Select Initially Hidden in the Options drop-down menu to hide an interactive
object when the exported file first runs. 

CREATING A MENU USING MASTER PAGES AND BUTTON BEHAVIORS
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6 Make a copy of the box you just created (Edit Þ Copy), and then paste it in
the master page (Edit Þ Paste).

7 With the new box selected, enter Btn_OurBrands_Over in the Object Name field
of the Interactive palette, and then click Enter. Note how Initially Hidden
already displays in the Options drop-down menu because you made a copy of
the “Btn_OurHistory_Over” interactive object to create the new box. 

8 Enter 314 in the Y: field of the Measurements palette to position the box
directly in front of the “Our Brands” text box.

9 Repeat the previous three steps until you create a mouse-over box for each
menu item. 

Use the following vertical positions to position the mouse-over boxes directly
over the appropriate text box in the menu:

• “Our History” (Y: 294)

• “Our Brands” (Y: 314)

• “Mountain Biking” (Y: 395)

• “Snowboarding” (Y: 415)

• “Surfboarding” (Y: 435)

• “Downhill Skiing” (Y: 455)

• “Store Locations” (Y: 536)

• “Corporate Offices” (Y: 556)

10 Bring the text boxes in front of the mouse-over boxes.

You can select an item that is behind another item by pressing
Command+Option+Shift on Mac OS or Ctrl+Alt+Shift on Windows while you
click in the layout. With the item selected, choose Item Þ Bring to Front to
bring the item to the front. You can also refer to the list of objects in the
Interactive palette to make sure the correct interactive object is selected
before you bring it to the front. 

CONFIGURING THE MOUSE-OVER EFFECTS
To make a mouse-over effect display when the end user places their mouse
over one of the menu items, configure a Mouse enter user event and a Mouse
exit user event on each menu item.

CONFIGURING THE MOUSE ENTER USER EVENT
To configure a Mouse enter user event on each menu item:

1 In the Interactive palette, click the Event tab.

2 Select Btn_OurHistory in the list of objects on the left side of the Event tab. 

CREATING A MENU USING MASTER PAGES AND BUTTON BEHAVIORS
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3 Choose Mouse enter in the User Event drop-down menu.

4 Choose Object Þ Show in the Action drop-down menu. The options for the
Show Object action display.

5 Choose Btn_OurHistory_Over in the Object drop-down menu to indicate the
object that should display when the user event occurs.

6 Choose Cover Þ Left to Right from the Effect drop-down menu, and then
enter 1 in the Time field to make the object display with a transition.

Configure the options in the Event tab to trigger the Show Object action when the
Mouse enter user event occurs. 

7 Repeat the previous steps until you configure a Show Object action for each
menu item. In the next section, you’ll configure the Hide Object action for
each menu item.

CONFIGURING THE MOUSE EXIT USER EVENT
To configure a Mouse exit user event for each menu item:

1 In the Interactive palette, click the Event tab.

2 Select Btn_OurHistory in the list of objects on the left side of the Event tab. 

3 Choose Mouse exit in the User Event drop-down menu.

4 Choose Object Þ Hide in the Action drop-down menu. The options for the
Hide Object action display.

5 Choose Btn_OurHistory_Over in the Object drop-down menu to specify
which object should hide when the user event occurs.

6 Choose Uncover Þ Right to Left from the Effect drop-down menu, and then
enter 1 in the Time field to make the object hide with a transition.

CREATING A MENU USING MASTER PAGES AND BUTTON BEHAVIORS
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Configure the options in the Event tab to trigger the Hide Object action when
the Mouse exit user event occurs. 

7 Repeat the previous steps until you configure a “Hide Object” action for each
menu item.

8 To preview the menu, display a layout page, and then choose Layout Þ

Preview SWF Þ Preview Layout or click Preview at the bottom of the
Interactive layout. QuarkXPress launches Flash Player and displays the exported
version of the layout. Press the right arrow key to display the “Welcome” page,
and then place your mouse over different menu items in the menu to see
the effects. 

In the next section, you’ll configure events to make pages display when the end
user clicks a menu item in the exported file.

CONFIGURING THE CLICK DOWN USER EVENTS
To make the appropriate page display by referring to its name in the Interactive
palette, name each page using the Page tab, and then configure a Click down
user event for each menu item using the Event tab. 

NAMING EACH PAGE IN THE INTERACTIVE LAYOUT
To name each page in the Interactive layout:

1 In the Interactive palette, click the Page tab.

2 Select 1 in the list of pages on the left side of the Page tab. 

3 Enter IntroPage in the Page Name field, and click Enter. The page 
name displays.

4 Repeat the previous two steps for each page in the Interactive layout using the
following page names:

2 WelcomePage

3 OurHistoryPage
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4 OurBrandsPage

5 BikingPage

6 BoardingPage

7 SurfingPage

8 SkiingPage

9 LocationsPage

10 OfficesPage

Use the Page tab of the Interactive palette to name the pages in an
Interactive layout. 

CONFIGURING THE CLICK DOWN USER EVENT 
To configure the Click down user event for each menu item:

1 In the Interactive palette, click the Event tab.

2 Select Btn_OurHistory in the list of objects on the left side of the Event tab. 

3 Choose Click down in the User Event drop-down menu.

4 To play a sound when the button is clicked by the end user, choose Choose
in the Event Sound drop-down menu, and then select the “btn_sound.wav”
sound file that is in the root of the project folder.

5 Choose Page Þ Display in the Action drop-down menu.

6 Choose Page Name in the Method drop-down menu to indicate that the page
should display by its name.

7 Select Btn_OurHistory in the Page drop-down menu to specify that the page
named “OurHistoryPage” should display when the end user clicks the
“Btn_OurHistory” interactive object.
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Configure the options in the Event tab to trigger the Page Display action when the
Click down user event occurs. 

8 Repeat the previous steps until you configure a Display Page action for each
menu item.

9 To preview the menu, display a layout page, and then choose Layout Þ

Preview SWF Þ Preview Layout or click Preview at the bottom of the
Interactive layout. QuarkXPress launches Flash Player and displays the exported
version of the layout. Press the right arrow key to display the “Welcome” page,
and then click different menu items in the menu to see the pages display.

CREATING AN IMAGE SEQUENCE TO ANIMATE A LOGO

An Image Sequence layout is an Interactive layout with a separate page for each
frame of the sequence. In this section, you will create an Image Sequence lay-
out and use it in an Animation object to display the Launch7 logo one letter
at a time on the “Introduction” page.

CREATING A NEW IMAGE SEQUENCE LAYOUT
To create an Image Sequence layout:

1 Choose Layout Þ New. The New Layout dialog box displays.

2 Enter AnimationLogoText in the Layout Name field. 

3 Choose Image Sequence from the Interactive Type drop-down menu.

4 Enter 161 in the Width field and 24 in the Height field. 
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Use the New Layout dialog box to create a new Image Sequence layout.

5 Click OK. A new Image Sequence layout named AnimationLogoText displays. 

When you create an Image Sequence layout, it automatically gets added to
the Shared Content palette so that you can place it in Presentation layouts,
which you will do later in this section. 

The new Image Sequence layout is automatically added to the Shared
Content palette.

CREATING THE FRAMES IN THE IMAGE SEQUENCE LAYOUT
To create the frames in the Image Sequence layout:

1 Switch back to the MultimediaShow layout using the layout tabs at the bottom
of the window or by choosing Layout Þ Go To.

2 In the MultimediaShow layout, make sure Window Þ Page Layout is checked,
and then double-click page 1 in the Page Layout palette. The “Introduction”
page displays. 

3 Select the letters of the “Launch” graphic that display on the “Introduction”
page, and then choose Edit Þ Cut to cut the letters from the layout.
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The “Launch” graphic displays in the “Introduction” page.

4 Switch back to the AnimationLogoText layout using the layout tabs at the
bottom of the window or by choosing Layout Þ Go To.

5 In the AnimationLogoText layout, make sure Window Þ Page Layout is
checked. The Page Layout palette displays a page for each frame in the
image sequence.

6 Double-click A-Master A page in the Page Layout palette to display the master
page in the Image Sequence layout.

7 Choose Edit Þ Paste to paste the “Launch” graphic you copied from the
“Introduction” page of the “MultimediaShow” layout into the master page of
the Image Sequence layout, and then position the graphic in the center of the
master page.

The “Launch” logo displays in one frame.

8 Double-click page 1 in the Page Layout palette to display the first frame of the
image sequence.

9 To create five additional frames in the animation, Control+click/right-click
on the first page in the Page Layout palette, and then choose Insert Pages.
The Insert Pages dialog box displays. 

10 Enter 5 in the Insert field of the Insert Pages dialog box, and then click OK.
Five additional frames display in the Page Layout palette, and each contains
identical content that was populated by the master page. 

11 Update the content in each frame to create a sequence of different images.
For example, delete each letter in the first frame except the letter “L”; delete
each letter in the second frame except the letters “L” and “A”; and continue
until each frame contains one more letter than the previous frame.
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The first three frames of the image sequence display the first three letters of the
“Launch” graphic. 

12 To preview the Image Sequence layout, choose Layout Þ Preview SWF Þ

Preview Layout or click Preview at the bottom of the Image Sequence
layout. QuarkXPress launches Flash Player and displays the exported version
of the layout. Note how each letter displays consecutively.

13 To change the frame rate of the image sequence so that it plays at a slower rate,
choose Layout Þ Properties to display the Layout Properties dialog box. 

14 Enter 1 in the Frame Rate field, and then preview the image sequence again. 

PLACING THE IMAGE SEQUENCE IN THE PRESENTATION LAYOUT
After you complete the image sequence, place it in the
“MultimediaShow” layout:

1 Switch back to the MultimediaShow layout using the layout tabs at the bottom
of the window or by choosing Layout Þ Go To.

2 In the MultimediaShow layout, make sure Window Þ Shared Content is
checked to display the Shared Content palette.

3 Select LaunchLogoText in the Shared Content palette and drag it to the
“Introduction” page (page 1) of the MultimediaShow layout. The image
sequence displays as a Composition Zones item in the MultimediaShow
layout. In addition, an Animation object was automatically created. This
Animation object contains the image sequence so that you can configure it
using the Interactive palette.
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Use the Shared Content palette to place an image sequence in a
Presentation layout.

4 To position the image sequence next to the Launch7 icon, select the
LaunchLogoText Composition Zones item, and then enter the following
values in the Classic tab of the Measurements palette:

X: 490 (horizontal position of upper left corner)

Y: 520 (vertical position of upper left corner)

5 To configure the Animation object that contains the image sequence in the
MultimediaShow layout, select the Animation object and then make sure
Window Þ Interactive Palette is checked to display the Interactive palette.

Use the Interactive palette to configure Animation objects.

6 Enter Animation_LaunchText in the Object Name field to update the name
of the object.

After you complete an image sequence and configure it in an Animation object,
you must create a Play Animation action to make it play in the exported file.
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CONFIGURING A PLAY ANIMATION ACTION TO PLAY THE
IMAGE SEQUENCE
There are several ways to apply a Play Animation action to an Animation
object that contains an image sequence. In this section, you will add a Play
Animation action to the existing script that runs when the “Introduction”
page (page 1) displays in the exported file.

You should have created the “IntroPageScript” in a previous section. To learn
more about creating this script, see “Playing background sound automatically
when the exported file is launched.”

To add the Play Animation action to the “IntroPageScript” script:

1 In the MultimediaShow layout, make sure Window Þ Page Layout is
checked, and then double-click page 1 in the Page Layout palette. The
“Introduction” page displays. 

2 In the Interactive palette, click the Script tab.

3 Select IntroPageScript in the left side of the Script tab.

4 Click the button. 

5 Select No Action in the Actions list. The Action drop-down menu displays.

6 Choose Animation Þ Play in the Action drop-down menu.

7 Choose Animation_LaunchText from the Animation drop-down menu. The
Play Animation action is added to the “IntroPageScript” script, which is set
in the Page tab to run when the “Introduction” page (page 1) first displays in
the exported file. 

The Play Animation action is added to the “IntroPageScript” script. 
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ADDING AN SWF ANIMATION

To add an SWF animation to the multimedia show, you must first create an
SWF object. After you create a SWF object, select the SWF file you want to
play in the exported presentation.

CREATING AN SWF OBJECT
To add a SWF animation to the “Introduction” page:

1 In the MultimediaShow layout, make sure Window Þ Page Layout is checked,
and then double-click page 1 in the Page Layout palette. The “Introduction”
page displays. 

2 Select the large, white picture box that displays on page 1. 

3 Make sure Window Þ Interactive Palette is checked to display the
Interactive palette. 

4 In the Interactive palette, click the Object tab.

5 Enter IntroPage_SWF in the Object Name field.

6 Choose SWF from the Object Type drop-down menu.

7 Choose Choose from the SWF drop-down menu to import an SWF file. The
Select SWF File dialog box displays.

8 Open the “Multimedia Show” folder, select “AnimatedLogo.swf” in the “swf”
folder, and then click Open. The SWF file will play automatically when the
exported multimedia show runs.

Use the Interactive palette to create SWF objects.

9 To preview the SWF file in the multimedia show, choose Layout Þ

Preview SWF Þ Preview Layout or click Preview at the bottom of the
Interactive layout. QuarkXPress launches Flash Player and displays the exported
version of the layout. Note how the imported SWF file plays on page 1.
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ADDING A VIDEO

To add a video to the multimedia show, you must first create a Video
object. After you create a Video object, you select the video to play in the
exported presentation.

CREATING A VIDEO OBJECT
To add a video to the “Snowboarding” page:

1 In the MultimediaShow layout, make sure Window Þ Page Layout is checked,
and then double-click page 6 in the Page Layout palette. The “Snowboarding”
page displays. 

2 Select the white picture box that displays on page 6.

Select a picture box to create a Video object.

3 Make sure Window Þ Interactive Palette is checked to display the
Interactive palette. 

4 In the Interactive palette, click the Object tab.

5 Enter Video_Snowboarding in the Object Name field.

6 Choose Video from the Object Type drop-down menu.
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7 Choose Choose from the Video drop-down menu to import a video file. The
Select Video File dialog box displays.

8 Open the “Multimedia Show” folder, select “pipe.AVI” in the “video” folder,
and then click Open.

9 Choose FLV from the Video Type drop-down menu.

AVI files are converted into FLV format when you export the multimedia show. 

The first frame of the video displays when you export the multimedia show.
To make the video play, you must apply a Play Video action, which you will
do in the next section using an Interactive button. 

Use the Interactive palette to create Video objects.

CONFIGURING BUTTONS TO PLAY, STOP, AND PAUSE THE VIDEO
There are two main steps to creating a video button such as play, stop, and pause
video control. First, you must create an interactive object, such as a Button object.
Second, you must assign a user event to the interactive object you created to
trigger the Video action. 

In this section, you will create a Button object out of an existing Button layout
that has been designed to look like a “Play” button. Then you will assign a user
event to the Button object so when the end user clicks the button, the
Video Þ Action runs and the video plays.

CREATING A BUTTON OBJECT TO PLAY THE VIDEO
To create a Button object to play a video:

1 Select the “Play” button that displays under the Video object on page 6. 

The “Play” button is already a Button layout named “ButtonPlay” in the project.
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Select the “Play” button to turn it into a Button object.

2 Make sure Window Þ Interactive Palette is checked to display the
Interactive palette. 

3 In the Interactive palette, click the Object tab.

4 Enter Button_VideoPlay in the Object Name field to name the “Play” button.

Button displays in the Object Type drop-down menu, and ButtonPlay displays
in the Button drop-down menu to indicate that the ButtonPlay layout is being
used for the button.

Use the Object tab to configure a Button object to play a video.

CONFIGURING THE BUTTON OBJECT TO PLAY THE VIDEO
Now that you have created a Button object, you have to configure it to play
the Video. To configure the Button object to play the video:

1 In the Interactive palette, click the Event tab.

2 Select Button_VideoPlay in the list of objects on the left side of the Event tab. 
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3 Choose Click up in the User Event drop-down menu.

4 Choose Video Þ Play in the Action drop-down menu.

5 Choose Video_Snowboarding in the Video Object drop-down menu.

Use the Event tab to assign a User Event that plays a video.

6 To preview the video on the “Snowboarding” page, choose Layout Þ

Preview SWF Þ Preview Page. QuarkXPress launches Flash Player and displays
the exported version of the “Snowboarding” page. Note how the video plays
when you click the “Play” button.

7 Repeat the previous two sections to configure “Stop” and “Pause” buttons for
the video. 

CREATING A SCROLLABLE TEXT BOX TO DISPLAY TEXT

When you turn a text box into a scrollable Text Box object, the box displays a
scroll bar, and the end user can select and copy text. Scrollable text boxes are a
dynamic way to display text in your Interactive layouts.

CREATING A SCROLLABLE TEXT BOX OBJECT
To create a scrollable Text Box on the “Our Brands” page:

1 In the MultimediaShow layout, make sure Window Þ Page Layout is checked,
and then double-click page 4 in the Page Layout palette. The “Our Brands”
page displays. 

2 Select the text box that contains black text on page 4.
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Select a text box to turn it into a scrollable text box.

3 Make sure Window Þ Interactive Palette is checked to display the
Interactive palette. 

4 In the Interactive palette, click the Object tab.

5 Enter TextBox_PageText in the Object Name field.

6 Choose TextBox from the Object Type drop-down menu. 

Use the Interactive palette to create scrollable text boxes.
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7 Choose Scrollable from the Display as drop-down menu.

8 To preview the “Our Brands” page, choose Layout Þ Preview SWF Þ

Preview Page. QuarkXPress launches Flash Player and displays the exported
version of the “Our Brands” page. Note how a scroll bar displays in the text
box so that you can easily scroll down to see all of the text.

EXPORTING THE SHOW TO A STANDALONE PROJECTOR FILE

Because Launch7 plans to use its multimedia show for multiple purposes, rep-
resentatives decide to export the show as a standalone Projector file. When you
export an Interactive layout as a standalone Projector file, the exported SWF
file and Flash Player are compiled into a single executable file that requires no
Internet connection, Web browser, or pre-installed version of Flash Player.

To export to a standalone Projector file:

1 Make sure a layout page in the multimedia show is displayed. 

You cannot export an Interactive layout when a master page is displayed.

2 Choose File Þ Export Þ Exporter for Macromedia® Flash™. The Exporter for
Macromedia Flash dialog box displays.

3 Choose a location to save the exported file.

4 Choose Windows Projector (*.exe) from the Save as type drop-down menu to
indicate that you want to export a standalone Projector file. 

On a Mac OS, choose to save your presentation as a Macintosh® Projector.
Macintosh Projectors can only be played on Mac OS.

The Exporter for Macromedia Flash dialog box lets you export the active Interactive
layout as a standalone Projector file.
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5 To display the exported presentation in full-screen mode by default, check
Export as Full Screen.

6 Click Save. A single standalone file is created in the location you specified.

ACCESSING THE COMPLETED PROJECT FILES

The completed QuarkXPress file for this project is located in the “Multimedia
Show” folder. 

1 To access the completed QuarkXPress file for this project, open the
“Launch7ShowFinal.qxp” file in the “Multimedia Show” folder.

2 To access files that were exported from the completed QuarkXPress file for this
project, open the “Completed Project” folder in the “Multimedia Show” folder. 
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